Thursday, December 11, 2014

How to fix the Pocket addon for Firefox

[Update2: Pocket eventually got updated, and my fixes and workarounds were no longer needed, so I deleted the repo. Me bugging them about it could have had something to do with it, but probably didn't. Either way, I'm glad they fixed it.]

[Update: Due to a request from getpocket.com I no longer provide the source code or binaries to the addon on Github. I have changed the Makefile to pull the broken extension from the web, and patch it locally (without hosting any code).]


Pocket (formerly ReadItLater) is a great tool that allows you to bookmark webpages and download them in order to read them later (get it?).

However, the Firefox addon is no longer supported, and a tiny change in the JavaScript engine has caused it to stop working. Hence BUG 1068790.

The JavaScript change is basically that variables declared using let are no longer accessible outside the block they were declared in. Fixing the addon turned out to be super easy. Just find-and-replace all 'let ' instances with 'var '.

Problem solved. I put the code on github so everyone can see how easy it is, and even packaged it for people who aren't so technical.

Keep rocking the open web!